06 septembre 2012
publié par 
La compilation d'une application pour iPod, iPhone ou iPad avec WINDEV Mobile 17 doit être faite avec une version de Xcode 4.3, ou 4.4, que la cible soit iOS5 ou iOS6.

Il est également possible d'utiliser les versions 4.1 ou 4.2 mentionnées dans les pré-requis de l'aide, sur un poste qui en dispose. Mais ces versions "anciennes" ont été retirées du site de Apple. Donc pour une nouvelle installation, il faut bien choisir Xcode 4.3, ou 4.4. L'aide en ligne sera rapidement réactualisée sur ce point.

La nouvelle version 4.5 de Xcode ne doit pas être utilisée sous peine d'obtenir le retour suivant :
no architecture to compile for (ARCHS=armv6 , VALID_ARCHS=armv7)

En effet afin d'être compatible avec l'iPhone 3 notamment, les projets Xcode générés par WINDEV Mobile 17 sont adaptés au jeu d'instructions des processeurs ARMV6 minimum. Dans la version 4.5 de Xcode Apple a supprimé le support de ARMV6, imposant ARMV7 en version minimale (donc plus de support de l'iPhone 3/3G).

Attention, ce changement de Apple concerne la compilation des projets, il n'a pas d'incidence sur l'exécution. Une application WINDEV Mobile 17 compilée avec Xcode 4.1 à 4.4, pourra parfaitement s'exécuter sous iOS6.

A noter que si Xcode 4.4 doit être utilisé avec WINDEV Mobile 17, la présence de Xcode 4.5 en parallèle peut être requise, si un test doit être fait sur un périphérique mis à jour avec iOS6. Ce point est détaillé dans le billet suivant :
Test d'une application sur un périphérique iOS6


< Retour

© 2019 PC SOFT. Tous droits réservés. Réalisé  avec WEBDEV