13 septembre 2013
publié par 
iOS7 est maintenant disponible pour les Développeurs, et sera en téléchargement officiel à partir du 18 septembre 2013. Une version de Xcode lui a été adaptée, la 5. Apple propose ainsi une mise à jour majeure de son système, qui impacte tous les développements pour iPhone, iPad et iPod. Voici les réponses aux premières questions que soulèvent ces nouvelles versions.

Les applications WINDEV Mobile 18 existantes peuvent-elles être déployées sous iOS 7 ?

Oui, il suffit de les compiler avec la version 63c de WINDEV Mobile 18, complétée de la mise à jour disponible dans les ressources pratiques (lien "Liste des modules correctifs...").
Les applications existantes qui sont déployées via l'Apple Store doivent également être recompilées, afin d'être soumises à nouveau à Apple.

Quelle version de Xcode utiliser pour recompiler une application WINDEV Mobile 18 afin qu'elle s'exécute sous iOS 7 ?

Les versions 4.6.3 et 5 de Xcode peuvent être utilisées. Attention cependant, en fonction de la version de Xcode utilisée pour la compilation, une même application n'a pas la même taille écran sous iOS 6 et iOS 7 (nouvelle gestion de la barre système de iOS 7, indépendante de WINDEV Mobile) :
  • pour que l'application s'exécute sans modification, il est donc impératif de recompiler avec Xcode 4.6.3.
  • pour recompiler avec Xcode 5, il faut modifier les fenêtres maximisées afin de laisser de l'espace pour la barre système. Ce point est détaillé dans la FAQ 8007 de notre site.

Si besoin les différentes versions de Xcode sont disponibles sur le site Apple :

< Retour

1 commentaire

coco
07/09/2017 - 16:49 - Répondre
je n'aime pas les mise a jour sa casse le develppement stable

Publier un commentaire : 
Votre adresse email ne sera pas publiée


© 2019 PC SOFT. Tous droits réservés. Réalisé  avec WEBDEV