De plus en plus de fournisseurs proposent l'utilisation de comptes eMail sécurisés (SMTP/IMAP) avec une double authentification.

Cela passe par une connexion de type OAuth vers le fournisseur de la boite Mail, cette connexion fournit un token qui devra être utilisé lors de la connexion aux boites IMAP ou SMTP.

 

Voici un exemple de code :

// Exemple de connexion IMAP avec un compte gMail
// et une double authentification
OAuthCnxGoogle est un OAuth2Paramètres
gMaSessionIMAP est un emailSessionIMAP

// Paramètres du serveur IMAP.
gMaSessionIMAP.AdresseServeur = "imap.gmail.com"
gMaSessionIMAP.Option = optionSSL
gMaSessionIMAP.Port = "993"

// Paramètres de connexion OAuth
OAuthCnxGoogle..ClientID = "ID de l'application"
OAuthCnxGoogle..ClientSecret = "ID secret de l'applicaton"
OAuthCnxGoogle..URLAuth = "https://accounts.google.com/o/oauth2/auth"
OAuthCnxGoogle..URLToken = "https://accounts.google.com/o/oauth2/token"
OAuthCnxGoogle..Scope = "https://mail.google.com/"
OAuthCnxGoogle..URLRedirection = "http://localhost:9000"
OAuthCnxGoogle..TypeRéponse = "code"

// Identification OAuth

gMaSessionIMAP..AuthToken = AuthIdentifie(OAuthCnxGoogle)

// Si l'identification a réussit, il fait se connecter à la boite eMail.
SI gMaSessionIMAP..AuthToken<>Null ALORS
SI EmailOuvreSession(gMaSessionIMAP) ALORS
// Session ouverte
SINON
// Erreur d'ouverture de la session.
FIN
SINON
// Erreur d'authentification.
FIN

 

 

Avec cette nouveauté, vous allez pouvoir anticiper les obligations à venir de certains fournisseurs.

< Retour

Publier un commentaire : 
Votre adresse email ne sera pas publiée


© 2020 PC SOFT. Tous droits réservés. Réalisé  avec WEBDEV